DOGE order issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted 6 months ago. Sep 28, 2018 - 16:41 PDT
Update
DOGE trading temporarily halted.
Posted 6 months ago. Sep 28, 2018 - 15:39 PDT
Investigating
We are currently investigating this issue.
Posted 6 months ago. Sep 28, 2018 - 15:25 PDT
This incident affected: Trading (Crypto Trading).