Options Market Data Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Mar 19, 2020 - 10:25 PDT
Investigating
Some users are experiencing issues with delayed options market data. We are working to resolve this issue as soon as possible.
Posted Mar 19, 2020 - 10:21 PDT
This incident affected: Market Data.