System Outage
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted about 1 month ago. Dec 12, 2018 - 22:14 PST
Investigating
All systems are currently down. We are investigating the issue and will restore service as soon as possible. Please check back for periodic updates as they become available.
Posted about 1 month ago. Dec 12, 2018 - 22:10 PST
This incident affected: Overall System (Overall System), Trading (Equities Trading, Crypto Trading, Options Trading), Corporate Actions (Dividends), Apps (iOS App, Web App, Android App), and Market Data, Order Status Updates, Bank Linking, Bank Transfers, Email Support.