Crypto Trading Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Sep 26, 2021 - 22:35 PDT
Investigating
We’re investigating an issue that’s affecting some customers’ ability to trade crypto. We are working to resolve these as soon as possible.
Posted Sep 26, 2021 - 20:36 PDT
This incident affected: Trading (Crypto Trading) and Market Data.