Crypto Trading Issue
Incident Report for Robinhood
Resolved
Crypto trading is back online. We’ve resolved the issue that was affecting it.
Posted Apr 16, 2021 - 09:27 PDT
Update
We’re experiencing intermittent issues with crypto trading due to heightened volumes. Because of this, some crypto trades may not execute right now.
Posted Apr 16, 2021 - 08:23 PDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 16, 2021 - 08:14 PDT
Identified
We’re experiencing intermittent issues with crypto trading due to heightened volumes. Because of this, some crypto trades may not execute right now.
Posted Apr 16, 2021 - 07:56 PDT
Update
We are continuing to investigate this issue.
Posted Apr 16, 2021 - 07:45 PDT
Update
We are continuing to investigate this issue.
Posted Apr 16, 2021 - 07:22 PDT
Investigating
We’re currently experiencing issues with crypto trading due to unprecedented volumes and are working to resolve them as soon as possible.
Posted Apr 16, 2021 - 07:19 PDT
This incident affected: Trading (Crypto Trading).