Trading Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Aug 14, 2020 - 07:32 PDT
Investigating
We are experiencing issues with trading. We are working to resolve this as soon as possible.
Posted Aug 14, 2020 - 07:26 PDT
This incident affected: Trading (Equities Trading, Crypto Trading).