Service Disruption
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Dec 08, 2020 - 06:56 PST
Investigating
We are investigating a service disruption.
Posted Dec 08, 2020 - 06:48 PST
This incident affected: Trading (Equities Trading, Crypto Trading, Options Trading, Fractional Equities Trading), Overall System (Overall System), Apps (iOS App, Web App, Android App), and Market Data, Order Status Updates, Bank Linking, Bank Transfers.