Crypto Trading Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted May 01, 2020 - 17:56 PDT
Update
We are continuing to investigate this issue.
Posted May 01, 2020 - 17:56 PDT
Investigating
We are experiencing issues with crypto trading. We are working to resolve this issue as soon as possible.

20190615-875357-2636238
Posted May 01, 2020 - 15:47 PDT
This incident affected: Trading (Equities Trading, Crypto Trading, Options Trading) and Bank Transfers.