Venue Equities Updates Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Mar 16, 2020 - 13:59 PDT
Investigating
A subset of orders at one of our market venues are experiencing update delays. We are working with them to resolve this issue as soon as possible.
Posted Mar 16, 2020 - 07:59 PDT
This incident affected: Trading (Equities Trading).